Network Now Supports 1.14.1

RFSMassacre

Owner
RFSMassacre
RFSMassacre
Owner
Network Now Supports 1.14.1
Quick announcement: the network now supports 1.14.1. This means you can join with the latest client. We hastily made it available as the new update came out. This also means Vanilla is 1.14.1 and we HOPE that it fixes the previous lag spikes with saving chunks and when traveling to the Nether. If you notice any bugs such as lighting or menus not having proper titles, please bear with it while it gets fixed. If you notice lag spikes on Vanilla, please let us know in the comment section.
 
Top